Switchgear

Post Reply
Harrisg80
Posts: 8
Joined: Tue Sep 18, 2018 5:45 pm
Location: Ruthin

Switchgear

Post by Harrisg80 » Sun Sep 23, 2018 6:43 pm

Looking for working switchgear.especially the left side.
Thanks
0 x

User avatar
lardmarc
Posts: 824
Joined: Tue Jun 23, 2015 8:56 pm
Location: Newton Abbot

Re: Switchgear

Post by lardmarc » Sun Sep 23, 2018 7:02 pm

Like this ?

Image

I'm sure https://www.forcemotorcycles.com/ got some new left switch gear in even though I can't find them on the website.
0 x
“Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so.” (Adams, 2009).

Harrisg80
Posts: 8
Joined: Tue Sep 18, 2018 5:45 pm
Location: Ruthin

Re: Switchgear

Post by Harrisg80 » Sun Sep 23, 2018 9:28 pm

Yes that the part but I want a used one. New will be too expensive.
I did look on the usual sites but found nothing.
The Harris uses Magura,but the mt version looks similar. I have the headlight flasher and side light but no main/did hence suspect the switch.
0 x

User avatar
lardmarc
Posts: 824
Joined: Tue Jun 23, 2015 8:56 pm
Location: Newton Abbot

Re: Switchgear

Post by lardmarc » Sun Sep 23, 2018 9:38 pm

Harrisg80 wrote:
Sun Sep 23, 2018 9:28 pm
Suspect the switch.
Undo the tiny little screw underneath and pop it out for a look. I've had solder break at the cable, fiddly soldering it back together.

Also check the fuse, it might look OK but minute break in it and it won't work.
0 x
“Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so.” (Adams, 2009).

Harrisg80
Posts: 8
Joined: Tue Sep 18, 2018 5:45 pm
Location: Ruthin

Re: Switchgear

Post by Harrisg80 » Sun Sep 23, 2018 9:43 pm

Thanks. Done both but no problem. The only thing I found was a bad earth above the engine. It did not sort the problem.
Also too a direct feed from battery to switch whilst apart..nothing..yet the flasher works! Odd!!
0 x

User avatar
Force Motorcycles
Posts: 323
Joined: Thu Jul 09, 2015 10:57 am
Location: Staffordshire

Re: Switchgear

Post by Force Motorcycles » Mon Sep 24, 2018 8:19 am

Hi,

We might have a solution for this - drop us an email and we'll see if we can help.

Force
0 x
Force Motorcycles - The World's Largest MT350 and MT500 Parts Dealer

The UK's Exclusive and Official ROTAX Parts Dealer

:arrow: Visit Our Online Store

:arrow: Follow Force Motorcycles on Facebook!

Harrisg80
Posts: 8
Joined: Tue Sep 18, 2018 5:45 pm
Location: Ruthin

Re: Switchgear

Post by Harrisg80 » Mon Sep 24, 2018 2:13 pm

Thanks for the suggestions and support.
I have resolved the problem internal break in the loom found by taking live feeds from each feed until the faulty wire was traced.
1 x

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests